PaperCraft Wiki

From the computer to the bookshelf.

User Tools

Site Tools


Sidebar

Translations of this page:

Learn About

Going Further

design

Design

Foreword

Building existing templates is a great hobby but it can also be very enjoyable to go through the whole process of designing the template yourself.

Firstly though you must ask yourself “why do I want to start designing?”. It’s not easy; especially if you’re new to 3D editing or papercrafting in general. It may sound a little harsh but you really must build plenty of other people’s models first to understand what makes a template work. Odds are if you’ve only done two or three simple to medium crafts you will not have the experience to detect potential mistakes in your own designs.

If you have thorough building experience and want to contribute to the archive of crafts out there then great! If you just want instant gratification of your talents, then this is a fast track to churning out poor forgettable unfolds. Take your time, start small, learn, test and develop. All the major designers had to start somewhere and practice makes perfect. Consider starting with a model that doesn’t have an existing template so you can be confident in producing something new and noticeable : a 100th template of Mario isn’t going to generate much appeal unless it brings something new to the table.

The golden rule is build what you design! This way you will figure out what you did right and wrong, and will progress your skills much faster.

So if you think you’ve got what it takes, read on!


Getting a 3D Model

First you need to obtain or create your 3D model. There are three ways to do this :

Ripping Models from Video Games

Ripping is an extremely common way of obtaining the exact 3D meshes and textures seen in game and usually is the first place to start when designing. Specifically it can refer to directly extracting all the assets from a scene in the open game, effectively being a case of “what you see is what you get”. This is great for getting ready made poses and all the items and accessories you might need in one single attempt.

But be aware that models taken directly from games should not be directly unfolded! 99.9% of the time they must be edited into a form that’s suitable and actually possible to build out of paper (see section C).

In the case of Nintendo games, ripping will be done by running copy of a game on an emulator, with a ripping function or other program running on top of it.

Nintendo 64 Models

The easiest way is to use 1964 with Lemmy’s Plugin installed by placing it in C:/Program Files/1964/099/plugin (or equivalent location on your computer). Then, in your C:/ directory, create a folder called VRML (all caps).

When you open a ROM (i.e. the copy of a game, downloadable from an appropriate website) you simply have to play it to get to the scene you want, pause the game, click Plug-ins > Video Settings and tick Export VRML. Close the box and unpause your game. The game will stutter for a moment as the scene is extracted, after which immediately open up the Video Settings box again and untick Export VRML to stop the ripping process looping constantly.

If everything has worked, inside your C:/VRML folder you should have hundreds of tiny .BMP texture files and one important file called output.wrl which is what you will then open in a 3D model program. The .WRL file can be opened in new versions of Blender by selecting File > Import > X3D & VRML97 (.x3d / wrl ). From there you can simply work on the model in Blender, or just use it to convert to a more common file format (.OBJ or .3DS) that you can open up in a 3D editing program you’re more familiar with.

Note that most N64 textures will appear to be broken at first due to the way the console applied the textures being incompatible with the modern texturing process. This is worth a lengthy tutorial in itself so please see XenonRay’s guide here.

Nintendo GameCube & Nintendo Wii Models

Similar to ROMs for N64 games, you can find ISOs which will allow you to play Gamecube and Wii games using the 32-bit version of the emulator, Dolphin (its 64-bit version doesn’t work for this method). In Dolphin you must then open Options > Graphical Settings > General and set the program to use Direct3D9 in the Backend box.

For ripping, you will need 3D Ripper DX. When you have both programs, run 3D Ripper DX and in the first box, locate the launch file, Dolphin.exe on your computer, make a note of the capture key and click Launch. If successful, when you load an ISO and begin to play the game, there should be yellow text in a top corner stating the program is ready to rip. To do so press the capture key and the game should freeze temporarily while the content is ripped. To find your content, look in your documents where there should be a folder called 3DReaperDX. The 3D data is located as one big .OBJ file in Frames. The textures will all be .DDS format, for which there are several free converters available on the internet to turn them into JPEGs or a more useable image type.

Note that 3D Ripper DX is a fussy program and will only work with 32bit versions of Dolphin. If it doesn’t load on top of Dolphin, try previous versions of both programs or running in compatibility mode. You may even have to specify the location of your ISO in the Command Line Parameter box before launching.

A ripped scene is likely to look squashed, and will need to be manually rotated along its axis to a correct undistorted position. Try to find a cube in the object and restore all its corners to 90 degrees angles: that is when you'll know that everything else will be correctly shaped. Some 3D editing software may have plugins than can do this automatically.

3D Ripper DX should be compatible with some PC games too so long as they use a compatible version of DirectX. Its latest builds have apparent compatibility with earlier DirectX versions, but this is buggy and unreliable. The program is pretty hit and miss though, so sometimes ripping from certain things just won’t be possible.

One rare thing 3D Ripper does is sometimes to deposit its files in a folder called C:/2/1 or C:/2/2. If your rips don’t seem to be in the correct place after extraction was supposedly successful, try searching your computer for “frame_” to see if the rips have been placed somewhere else.

Unpacking Video Game Models

Unpacking is different to ripping in that it refers to browsing the games’ files, finding your desired character or item and textures, and exporting them into a format that can be opened by 3D model editing software. Different games have different (and possibly extremely obscure) packed file formats, so the methods of unpacking can be very different, numerous, and impractical to list all here. Consider searching emulation and 3D modelling forums for specific information.

The advantage over ripping is that you can pinpoint the exact 3D content and textures you’re looking for without having to rip all sorts of scenery and junk geometry along with it. Additionally, ripping from some games could require you to spend time playing it to get to the section you want to extract from.

Creating 3D Models from Scratch

While ripping is a popular starting point, there can be great satisfaction in building your own 3D model from scratch. And of course it’s the only option if you want to create a model of something from a 2D game!

Since ripped game models almost always start out in a pretty bad state for papercraft, making your own from the beginning can let you bypass many problems that would make a model unsuitable for building. From the ground up you can design it to avoid intersecting parts, give it geometry ideally suited to paper construction and carefully control the complexity.

A good way to make your model look as much like the character as possible is to use background images of the front, side, and back of your character. You can then model your character off those and get all of the proportions correct. It is a good idea to make everything one object and to have an even mesh.

When texturing scratch models, it is best not to use your background image as your texture but draw them yourself using the uv editor. This makes much higher quality textures. If your character has already been made in a game, you can rip the model and use the textures from the game. These will be high quality and you will get much more detail.


Editing the 3D Model

Unfortunately, most of the time ripped models cannot be unfolded directly and will require some or even a lot of effort to correct the mesh into a shape that can feasibly be built with paper.

In a digital 3D space, polygons are like ghosts : they can intersect and cross through each other without issues, unless they have an invisible hitbox. In reality, though, you cannot pass solid objects through each other so, you must take this in consideration when correcting a model.

Editing models is a somewhat repetitive process and it is pretty much the same in each program. However, since it is free, open-source and cross-platform, we will explain here how to use the very popular Blender project.

Using Blender

Before being able to create and edit you model, you must have at least some knowledge about the program that you are using. One popular program for 3D modeling is Blender.

Blender provides many useful shortcuts to make your modeling quicker and easier, so you will need to learn a few to model with it.

Shortcut Action
Right Mouse Click Selects the edge/face/vertex that your mouse is hovering over.
Left Mouse Click Moves the cursor to your mouse.
Middle Mouse Button Rotates your view around the object.
A Selects everything in the current object.
Ctrl + I Inverts current selection.
Z Toggles wireframe mode.
G Moves the selected parts.
S Scales the selected parts.
R Rotates the selected parts.
E Extrudes selected parts.
G/S/R/E + X/Y/Z Limits movement, scaling, rotation or extrusion to the X, Y or Z axis.
G/S/R/E + Shift + X/Y/Z Limits movement, scaling, rotation or extrusion to the plane that EXCLUDES the chosen axis.
M + X/Y/Z Mirrors selected geometry along the X, Y or Z axis.
X, or Delete Deletes the selected parts.
B Mouse becomes a selection box for click-and-drag part selection.
C Makes your mouse a paintbrush-like tool that selects everything you click on.
TAB Switches your viewing mode to the last viewing mode used.
SPACEBAR Provides a search bar to search through the various functions.
CTRL + R Adds a line of vertices that stretches around the model.
ALT + M Merges the selected parts into 1 vertex.
W Brings up tool selection menu. In Edit Mode it’s useful for Merge, Subdivide, Flip Normals and Remove Doubles.
Ctrl + J Joins all selected objects together. You need to do this before exporting to Pepakura.
Ctrl + Shift + F Swaps alignment of triangular faces. Can be useful for ironing out awkward shapes.
F, or Shift + F (with selected vertices or edges) Creates an edge/face or fills in gaps between selected vertices.
W + 0 Flips normal maps, useful if textures import inside out.
Shift + D Creates a duplicate of the selected geometry.
Alt + S Moves selected vertices inwards or outwards.
Shift + V Slides selected vertex along an edge.

Simplifying the 3D Model

You need to make the model as simple as possible but with enough detail. This process has a few steps.

Simplification by Deletion

The first step is simplifying; probably the biggest part of editing a complex model. Every ripped model has what you call loops. Loops are when a row of faces form up a ring around a part of the model. First, delete a loop that you would like to simplify.

Next, open the UV editor. The UV editor is for fixing or adding textures to your model. It is almost certain that the program you are using has one. Then select the two loops above and below the loop that you have deleted. They will open in the UV editor. In the editor, the loops look like a flattened version of the model. You should see a spot where the deleted loop was. There are vertices that were previously touching the loop on the top and bottom. Select two on either loop and scale them until they are touching. Repeat this process until the two faces are completely connected. If you skip the UV step, the textures will be messed up. Now you can simplify that spot on the model. Select two vertices vertical to each other. It looks like this :

Once you have the two vertices selected, press merge. In blender, press Alt - M and in Metasequoia press Ctrl - J. Do this for the whole length of the loop. Continue this process throughout the entire model.

Simplification by Merging

In Blender you can use a mixture of Merge and Collapse to simplify loops without the need to delete parts. Select two or more vertices, hit W and select Merge, then an option in the sub menu. Collapse is the most useful as can merge a pair (or trio etc) of vertices into a ‘central’ position. Collapse is great because it is non-destructive to UV maps so texture errors will be less of a problem. Textures can be squashed or overstretched occasionally though. Merge’s other options such as At First and At Last will merge all selected vertices into the position of the first or last one that was selected. This is useful if you want to maintain a fixed position or proportions of an edge but unlike Collapse it is destructive to UVs and any changes will create gaps that need to be fixed in the manner described earlier.

Posing the 3D Model

Posing can prove to be difficult for many people, but with practice you can pose your characters in many different ways. Some tips to get you started posing like a master are :

Try to keep the original length and width of the part you are moving. If a part can’t be posed without drastically stretching the proportions of it, try finding a similar but simpler pose to make.

If you are posing a humanoid, remember : You are a humanoid too! You can use your own body parts as reference to the 3D model you are posing.

Don’t pose a model so that parts of it are conflicting with other parts. The arm of your character might be able to go through its body in the 3D modeling program, but in real life, it will be very difficult to get that to happen.

Pose your model after you have finished simplifying and editing. Your pose might be obstructing your view of a glitch in the textures that you have to fix.

* There is no specific way to pose a certain model, so don’t try to Google “How to pose Mario”!


Unfolding the 3D Model

Once your model is exported from Blender, all the following steps are made using Pepakura Designer.

Importing the 3D Model

To import a 3D model, click on Open (Document icon OR File/Open…) and fetch the file.

Here are the compatible file types that you can import in Pepakura Designer.1)

Program Filetype Comments
Wavefront OBJ Usually the most-used format for its great compatibility, but sometimes you may have to import your texture files manually.
AutoCAD DXF
Metasequoia MQO
3DS Max 3DS Often implies texture problems and other issues.
Lightwave LWO
STL (Binary format) STL
Google Earth 4 KML, KMZ With the newest versions of SketchUp, you may run into problems. For this reason, we suggest you instead export to OBJ file format.
Collada DAE

* These formats may not load properly, depending on output applications and versions. By example, recent KMZ versions are now often buggy and unrecommended.

For best compatibility, we suggest that you always keep the texture images in the same folder as the 3D model and that you don’t move this folder. Otherwise, texture problems will surely occur.

Sometimes, when you import your model, the file format you used (e.g. OBJ) won’t be oriented. Therefore, the program will ask you to precise the orientation of the model (Bottom, Front). Only flip the faces if they look blue-grey (and aren’t textured).

Sometimes, particularly with the OBJ format, you will have to import your texture files manually. To do so, go in Settings > Texture Settings… and a window will pop up. You’ll then see every texture material used by the model. Select the missing texture and click on Specify Texture Image… then fetch the image file.

If you cannot get your models to load in Pepakura without the program crashing, one common reason is that you have not merged your 3D model into one single object. Pepakura often struggles with 3D files that have multiple selectable objects when opened in Blender or Metasequoia etc so make sure before you export, select everything and merge all the objects into one.

An excessive amount of red lines in a Pepakura model often means it cannot work out the proper ‘edges’ because there are duplicate vertices stacked on top of each other. This most commonly occurs with ripped N64 models. In Blender, the quick way to remedy this is to select your model in Edit Mode and use W > Remove Doubles.

Note that edges that have three or more faces converging will always create a red lined edge in Pepakura.

Unfolding

Unfolding is where you take the 3D model in Pepakura and begin to break it up into parts that can be printed. It sounds simple, but this is a critical stage that really determines the overall quality of the build presentation. Its easy for beginners to unintentionally rush out a poor template with the auto-unfold feature, but there are several tips that can be followed to improve overall template presentation and buildability.

  • Firstly, buy a code for Pepakura Designer (it costs $48). You will need the save function to be working in an unlocked version because it is a very bad idea to try and unfold something in a single try. Without the ability to save as a .PDO file you cannot return to the model later, and you’ll only be able to produce unchangeable image files.
  • Do not just use the Unfold button on its own as this will almost always produce an unbuildable or unoptimised layout. Plan the joins yourself with the knife tool (Specify Open Edges), or manually rework the results of the auto unfold to something more appropriate.
  • Set a suitable scale for you model using 2D Menu > Change Scale > Scale Factor. Make sure the model is not too small or excessively big for its complexity.
  • When unfolding long narrow objects such as a tube or limb, split it into horizontal rings, not vertical strips. Ringed constructions are far easier to build.
  • You can turn lines on and off, or edit their appearance using Settings > Other Settings > Line Style.
  • Several smaller, sensibly shaped pieces are better than a massive sprawling one.
  • Spend plenty of time on your unfold. Unless it is a very basic shape, spending just 5 minutes on it is not going to produce a good template.
  • Tab alignment is more important than you might think. Paper has a physical thickness and the edge that glues over a tab makes a tiny ‘overhang’. White paper edges show up unless coloured prior to gluing but overhangs are unavoidable. The consensus is that it’s far better to have the overhangs face downwards as they are less visible this way. So if you make something out of horizontal rings, most of the time you should run tabs along their top edges. Consider the shape of the object and how the tab alignment will affect the visibility of the overhang/overlap between pieces.

Above: A segment of the legs from the Twili Midna template by XenonRay and Squeezycheesecake. The left has the tabs aligned and sized appropriately for the shape of the model. All seams will ‘point’ downwards making them less visible and parts are numbered for an instruction or build order guide. The right shows messy tabs that switch their alignment irregularly. The seam face will be all over the place and will not be neat when built.

However it is possible to make ‘zipper’ seams with alternating tabs. Again this will be less tidy as the parts must physically zig-zag around each other, especially with thick paper, but it can effectively show you how parts go together from the pieces alone. And for certain models it can hold the parts together better while assembling. In all cases consistency is the key.

Exporting the Template

Once you have completed your unfold in Pepakura, save the template as a PDO file. By doing this you can give builders the option to use Pepakura Viewer for a good 3D reference and part guide for your model, making it much easier for others to understand. PDOs are the best file type to provide but because not everyone will have or want to use Pepakura it’s a good idea to create a copy of the template in a more common format. Remember to provide both a lined and lineless version of the template!

BMP Export

Under File > Export in Pepakura Designer are a variety of export options to choose from: the most useful being to save as a .BMP image per sheet. For the best results choose a large enough image size to prevent any quality loss.

PDF Export

By default there is no option to export as PDFs. But a number of programs such as CutePDF Writer are freely available which allow you to ‘print’ all the sheets to a single PDF file. This makes a high quality all-in-one document that people can print from and is arguably the best option for sharing the template in a non-PDO format.

Locked PDOs

In the Export menu you can also choose to create a locked PDO file which can only be opened in Pepakura Viewer where no changes can be made. This is useful if you want to prevent theft of your work, or provide a set template to reference from. However please appreciate that sometimes people may want to change the scale, line style, or make quick edits to suit their papercrafting preferences and a locked PDO could put them off. The choice is yours but just be mindful of the pros and cons. Also, if you password-protect your model, don’t forget the password in case you want to add modifications in the future!

Gathering the Files

Once you have your template files ready it’s time to pack them into a ZIP or RAR archive (see Section A for the programs that can do this).

As well as placing your PDO and other template files into the archive, other things you can include are:

  • Reference photos of a finished model;
  • Notes on the template;
  • Photographic instructions;
  • Alternative textures or recolours of the template.

Publishing the Template

On Nintendo Papercraft

We’ve made our best effort to make model submitting as easy as possible. Simply follow the instructions on this page to submit your design. We’ll then evaluate your submission and if everything’s okay, your model should get posted on the blog in the next free slot.

If you're a blog poster, read on.

First, once you've got your account, go to nintendo-papercraft.com/wp-admin/ in your Web browser.

This will redirect you to the WordPress.org log in page. Complete your credentials and click on 'Log in'.

You will land on the Dashboard, where you can access to pretty much anything behind-the-scenes. To compose a new post, click on 'Add New' under the 'Posts' menu.

You will land on the Add New Post page. Complete the following info:

  • Enter title here: Write the name of the subject represented by the model. For example, 'Kokiri Sword'
  • Text input box: Write a description of the subject and also of the template itself. For example, if your subject is a Kokiri Sword, describe what is its in-game purpose, how many pages and pieces are contained in the template, who designed the template and took the photo, etc. Don't forget the download link and appropriate credits!
  • 'Publish immediately' (Under Publish): Click on 'Edit'. Change this to the date you want the post to be published. (We publish one Cubeecraft every Tuesday and one regular model every Friday.) Click on 'OK'.
  • Categories: Check whichever categories best fit the model and subject. Choose at least one Game category and choose a single 'Difficulty' category.
  • Tags, Discussion, Sharing: Ignore these.

Next, add a picture of the final build in the post. Click on 'Add Media'.

Go to the 'Upload Files' tab. Drag and drop the image.

Once uploaded, go to the 'Media Library' tab. Set the Alignment to 'Right'. Click on 'Insert into post'.

Finally, set the Featured Image. Click on 'Set featured image' under Featured Image.

  • If the image is in landscape, select it from the Media Library.
  • If the image is in portrait, upload it again and read on.

To crop an image directly in WordPress, select the image in the Media Library and click on 'Edit image'. In the image editor, drag the desired cropped landscape frame and click on the Crop button. Click on 'Save' when done.

Also, if you want to upload the template files directly on the Nintendo Papercraft server, do the same thing as with images until you set the Alignment. Then, instead of inserting the file into the post, copy the Media File URL found under 'Link To'. Close the pop-up.

When everything is ready for publication, click on the blue 'Schedule' button.

design.txt · Last modified: 2015/11/10 12:26 by Gilles-Philippe